dCustomHinge EnableMotor does not work anymore

Report any bugs here and we'll post fixes

Moderators: Sascha Willems, Thomas

dCustomHinge EnableMotor does not work anymore

Postby Lax » Tue Apr 09, 2019 12:33 pm

Hi,

During my tests I detected, that EnableMotor of dCustomHinge does not work anymore.
I see, that all parameter are set correctly and even in the 'SubmitConstraints' function, the acceleration is calculated, but the issues is, that 'SubmitConstraints' is just called once. I do not know how to trigger, that the function is called always.

Has somebody any idea, what is going wrong, or maybe I do something wrong?

I also updated to the newest newton version.

Best Regards
Lax
Lax
 
Posts: 116
Joined: Sat Jan 08, 2011 8:24 am

Re: dCustomHinge EnableMotor does not work anymore

Postby Dave Gravel » Tue Apr 09, 2019 12:54 pm

Here it seen to work normally.
Do you have add some friction ?
Without friction It can look like not working.
You search a nice physics solution, if you can read this message you're at the good place :wink:
OrionX3D Projects & Demos:
https://www.facebook.com/dave.gravel1
http://orionx3d.googlepages.com/
https://www.youtube.com/user/EvadLevarg/videos
User avatar
Dave Gravel
 
Posts: 713
Joined: Sat Apr 01, 2006 9:31 pm
Location: Quebec in Canada.

Re: dCustomHinge EnableMotor does not work anymore

Postby Lax » Tue Apr 09, 2019 1:54 pm

Thanks for the reply. I also increased friction for testing. But still, nothing is rotating.
Lax
 
Posts: 116
Joined: Sat Jan 08, 2011 8:24 am

Re: dCustomHinge EnableMotor does not work anymore

Postby Dave Gravel » Tue Apr 09, 2019 2:04 pm

Strange, I have update the newton dll too and it look to work normally again.
I have 2 or 3 demos using the hinge motor and all working ok.
Sorry I don't have more idea about what can cause the problem :(
exemple : https://www.youtube.com/watch?v=H31xm9BFrm8
You search a nice physics solution, if you can read this message you're at the good place :wink:
OrionX3D Projects & Demos:
https://www.facebook.com/dave.gravel1
http://orionx3d.googlepages.com/
https://www.youtube.com/user/EvadLevarg/videos
User avatar
Dave Gravel
 
Posts: 713
Joined: Sat Apr 01, 2006 9:31 pm
Location: Quebec in Canada.

Re: dCustomHinge EnableMotor does not work anymore

Postby Lax » Tue Apr 09, 2019 2:08 pm

Hi Dave,

thanks for the nice video! I saw that you set the friction to 1000. I did the same now it works. :D I always thought, friction should not be higher as 1.0? Or in the past, no friction was required.

Best Regards
Lax
Lax
 
Posts: 116
Joined: Sat Jan 08, 2011 8:24 am

Re: dCustomHinge EnableMotor does not work anymore

Postby Dave Gravel » Tue Apr 09, 2019 2:12 pm

1000.0 is a heavy value, It's only a experimental test maybe it can't work good with all situations.
You can maybe try lower value and use higher speed.

Edited:
Exemple with my bike I need to use lower value.
Something like 300 400 or the wheel can start to make strange things.
Last edited by Dave Gravel on Tue Apr 09, 2019 2:22 pm, edited 1 time in total.
You search a nice physics solution, if you can read this message you're at the good place :wink:
OrionX3D Projects & Demos:
https://www.facebook.com/dave.gravel1
http://orionx3d.googlepages.com/
https://www.youtube.com/user/EvadLevarg/videos
User avatar
Dave Gravel
 
Posts: 713
Joined: Sat Apr 01, 2006 9:31 pm
Location: Quebec in Canada.

Re: dCustomHinge EnableMotor does not work anymore

Postby Julio Jerez » Tue Apr 09, 2019 2:16 pm

friction is a misleading term, it does not mean a friction coefficient, friction is a force or a torque.
in the case of a contact is a coefficient that goes from zero to one, but that's because the solve find he contact normal force and multiple that force by the coefficient to get a friction force.

In the case of a motor, the friction means directly the max torque the motor is allowed to use to spin the axel.

the good thong is tha you can look up in any data sheet of any motor for the Max torque and use that as reference for the joint,
Dave is right 1000 newton*meter torque is a mighty powerful motor,
you may not want some that powerful.
Julio Jerez
Moderator
Moderator
 
Posts: 11048
Joined: Sun Sep 14, 2003 2:18 pm
Location: Los Angeles

Re: dCustomHinge EnableMotor does not work anymore

Postby Lax » Tue Apr 09, 2019 2:38 pm

Ok, now I understand, max torque sounds better.
I will lower the strength of my motor :)

Thanks!
Lax
 
Posts: 116
Joined: Sat Jan 08, 2011 8:24 am


Return to Bugs and Fixes

Who is online

Users browsing this forum: No registered users and 1 guest