lost Torque too quickly!!

A place to discuss everything related to Newton Dynamics.

Moderators: Sascha Willems, walaber

lost Torque too quickly!!

Postby bryanevil » Wed Oct 08, 2008 7:49 pm

Hi all


I was trying to throw a ball (by using the setVelocity) with a spinning force, I use setOmga to do that. The aim is to use the torque to change the direction of the ball when it first impact on the floor.

I wonder am I doing it right because my observation was that the torque setup at the beginning was losing so quickly during the throw. When it first touch the ground the torque has became so insignificant it could not change the ball direction.

I have setup the material pair for the ball and the ground with a large friction 50 49, but it didnt make any difference than the default one.

I also tried to use the setAngularDamping and gave 0 values, and it did not help either.

setTorque , setOmga or addTorque at the callback is not acceptable solution because it is not realistic.

I wonder how can i stop the torque lose so quickly during the throw? It just doesnt make sense to me, at the real world, the spinning force would not lose so quickly and when it hit the ground it will certainly change the ball direction, isnt it?

Any suggestion and explanation would be most welcome.


Thanks

Bryan
bryanevil
 
Posts: 4
Joined: Thu Sep 25, 2008 6:45 pm

Re: lost Torque too quickly!!

Postby JernejL » Thu Oct 09, 2008 12:48 pm

It is possible that your materials are set so that they disperse a lot of force in elasticity or friction response between the ball and the floor.
Help improving the Newton Game Dynamics WIKI
User avatar
JernejL
 
Posts: 1531
Joined: Mon Dec 06, 2004 2:00 pm
Location: Slovenia

Re: lost Torque too quickly!!

Postby bryanevil » Thu Oct 09, 2008 7:04 pm

I tried to use the default material at first, but it didnt work that is why i used the user setup material pair. I did play with the friction values, it did not improve my suitation. I am quit confidance problem was the ball Torque beacuse it was constantly losing greatly during the throw, I trace it inside the call back function. At the first instance , torque was 45, and when i first contact the ground torque was dropped to 4 something. btw , 45 seems to be maximum, so greater value setup does not help.

I need help please! Thank you

Bryan
bryanevil
 
Posts: 4
Joined: Thu Sep 25, 2008 6:45 pm

Re: lost Torque too quickly!!

Postby JernejL » Thu Oct 09, 2008 7:16 pm

it is not just friction parameter, set others as well (such as elasticity).

also on the other hand, do you have proper inertial values and mass set for the sphere?
Help improving the Newton Game Dynamics WIKI
User avatar
JernejL
 
Posts: 1531
Joined: Mon Dec 06, 2004 2:00 pm
Location: Slovenia

Re: lost Torque too quickly!!

Postby bryanevil » Fri Oct 10, 2008 11:10 pm

I changed the default Elasticity value, but no help...as well as softness.. had anyone ever done this before?
bryanevil
 
Posts: 4
Joined: Thu Sep 25, 2008 6:45 pm

Re: lost Torque too quickly!!

Postby Julio Jerez » Sat Oct 11, 2008 8:38 am

When you create the body set the angular drag coeficients to zero, tha will make it better.
It will never be pefect bacuase numerical integration is never exact, but it will be much better.
Julio Jerez
Moderator
Moderator
 
Posts: 11155
Joined: Sun Sep 14, 2003 2:18 pm
Location: Los Angeles

Re: lost Torque too quickly!!

Postby bryanevil » Sat Oct 11, 2008 6:54 pm

angular drag do you mean Angular Damping? I have already changed it to 0 at the first place...
bryanevil
 
Posts: 4
Joined: Thu Sep 25, 2008 6:45 pm


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 4 guests