Newton 3.14 vehicle problem

Report any bugs here and we'll post fixes

Moderators: Sascha Willems, Thomas

Re: Newton 3.14 vehicle problem

Postby Julio Jerez » Mon Mar 07, 2016 10:57 am

what I am doing now is that I will unified
void NewtonWorldConvexRayCast and int NewtonWorldConvexCast
to be only NewtonWorldConvexCast,

NewtonWorldConvexCast is implemented and is very robust, then at some point base on somebody request I implemented NewtonWorldConvexRayCast which take some shortcut by dealing directly with the shapes, but is doing so, over the evolution of the engine NewtonWorldConvexCast has evolve with it while NewtonWorldConvexRayCast has not.

an now that I nee to use it I see that it fails, then I realized that those are bot the same function with different interface, so unifying both is just a clean up processed.

This should be committed some time today and then we can test the car again
Julio Jerez
Moderator
Moderator
 
Posts: 11048
Joined: Sun Sep 14, 2003 2:18 pm
Location: Los Angeles

Re: Newton 3.14 vehicle problem

Postby Julio Jerez » Fri Mar 11, 2016 10:31 am

Ok I think I finally completed the re factoring of the collision system and I have all the demos using the newer convex cast functions.
I just added the fumtionality to the vehicle, and drove around a bit.

Now I will spend the weekend tuning the rest of the parameter that I have block on the vehicle, by can you try it out to see if the wheel jump bug is gone.
I expect to be completely gone, unless there is still a bug some where.

If the jump bug is still there, can I get a demo form you that place only one car and that link to a newton.dll so that I can see what exactly is that is going on.

you game me some pieced of meshes but that does not really help me because you use then as building block to create a large scene, and that is when the wheel jump bug happens.
It may be some thing I am no aware about.

But please try the last commit I am fairly confident that but should be gone.
Julio Jerez
Moderator
Moderator
 
Posts: 11048
Joined: Sun Sep 14, 2003 2:18 pm
Location: Los Angeles

Re: Newton 3.14 vehicle problem

Postby e3dalive » Sat Mar 12, 2016 12:14 pm

that sounds awesome, i will try it and get back to you
e3dalive
 
Posts: 87
Joined: Thu Feb 05, 2015 5:20 am

Re: Newton 3.14 vehicle problem

Postby e3dalive » Mon Mar 14, 2016 11:59 am

add paths to vs2012 and other projects to get that file - dTimeTracker.h
for some reason car instantly hits some invisible body, i enabled newton debug drawing there is nothin in front of the car, also now car don't jump on different meshes, now car flyes into space at different meshes, i will try to fiddle with settings maybe get it more stable
e3dalive
 
Posts: 87
Joined: Thu Feb 05, 2015 5:20 am

Re: Newton 3.14 vehicle problem

Postby e3dalive » Mon Mar 14, 2016 12:42 pm

here's helicopter with explosions video :D https://youtu.be/QEZSW0DuWzs hopefully it will be helpfull
p.s. i've treied previous configuration that worked on previos test videos but it doesn't work either, perhaps you changed the way car is created or added additional parameter, i will look more into it. Worst case i give you deploy that is linked against newton.dll and you can see the bug for youself.
e3dalive
 
Posts: 87
Joined: Thu Feb 05, 2015 5:20 am

Re: Newton 3.14 vehicle problem

Postby Julio Jerez » Mon Mar 14, 2016 1:25 pm

make sure you got latest code, I have being making many changes on the collision system.

also you think that after you see if every thong is right, that I can get a simple running demo that I can test for those bugs? The demo should link to the Netwon.dll so that I can attach and debug it.
There may be something you are doing that I am missing.
Julio Jerez
Moderator
Moderator
 
Posts: 11048
Joined: Sun Sep 14, 2003 2:18 pm
Location: Los Angeles

Re: Newton 3.14 vehicle problem

Postby e3dalive » Mon Mar 14, 2016 1:45 pm

i've used latest svn i've downloaded from github
i also noticed there is a crash here in new raycast function: https://www.dropbox.com/s/os8hy859krt8a ... 7.png?dl=0
e3dalive
 
Posts: 87
Joined: Thu Feb 05, 2015 5:20 am

Re: Newton 3.14 vehicle problem

Postby Julio Jerez » Mon Mar 14, 2016 2:00 pm

Oh you have a crash in collision scene. I probable has to do some update there too.
How about the test demo so that I can debug this directly in you game?
you are doing stuff that most people aren't no doing and is a good test bet .

Basically I embarked is a big revamping of the collision system. and this si why you see these bugs, but it is all for the better. I just did not think it will take me so long.

all of these was no gratuitously, I need the convexcast to work general for every thing, and before I have tow version of then with tow different algorithm I have convexCast and RayConvexCast.
when use independ they where boh fone, but if I use one as a precondition of the other, they generate inconsisten results. and the vehicle required that functionality.
Julio Jerez
Moderator
Moderator
 
Posts: 11048
Joined: Sun Sep 14, 2003 2:18 pm
Location: Los Angeles

Re: Newton 3.14 vehicle problem

Postby e3dalive » Tue Mar 15, 2016 5:42 am

You've also commented out serialization functions, lol everything broke, i cleanup my serialization code, so you have simple scene with 4x roads + 1 car on it and it's crashing at the place where i sent you screenshot, i uploaded deploy for you test it's ~2gb here, it's linked against 2012dll debug newton version, if you don't have dx11 gpu i can tell you what you need to do to enable cpu render. https://drive.google.com/file/d/0B-rAar ... sp=sharing
e3dalive
 
Posts: 87
Joined: Thu Feb 05, 2015 5:20 am

Re: Newton 3.14 vehicle problem

Postby Julio Jerez » Tue Mar 15, 2016 8:09 am

e3dalive wrote:You've also commented out serialization functions,


I am changing some of the collision shape algorithm yes, serialization me be broken, but
I do not remember doing that what did you do to test serialization broken?
Julio Jerez
Moderator
Moderator
 
Posts: 11048
Joined: Sun Sep 14, 2003 2:18 pm
Location: Los Angeles

Re: Newton 3.14 vehicle problem

Postby e3dalive » Tue Mar 15, 2016 9:18 am

i enabled debug version of newton and got assert inside one of the serialization fuctions for convex and triangle meshes
e3dalive
 
Posts: 87
Joined: Thu Feb 05, 2015 5:20 am

Re: Newton 3.14 vehicle problem

Postby Julio Jerez » Tue Mar 15, 2016 1:13 pm

e3dalive wrote:so you have simple scene with 4x roads + 1 car on it and it's crashing at the place where i sent you screenshot


ha thanks, let me fix those crash bug first on my side, that you give an executable so that I can test the real bug, there is no point of having a crashing demo that is crashing on my side.

My guess is that this crash is because of DLL function table binge wrong, I am naming some changes to some collision routine to make the more general and having fewer versions.
This can cause those kind of mysterious crashes.
Julio Jerez
Moderator
Moderator
 
Posts: 11048
Joined: Sun Sep 14, 2003 2:18 pm
Location: Los Angeles

Re: Newton 3.14 vehicle problem

Postby e3dalive » Sun Mar 27, 2016 4:03 am

Did you had the chance to download the files i've uploaded to fix car wheel bug?
e3dalive
 
Posts: 87
Joined: Thu Feb 05, 2015 5:20 am

Re: Newton 3.14 vehicle problem

Postby Julio Jerez » Fri Apr 22, 2016 11:11 am

Ok, I took a long time, but I believe I finally have the bug fixed.
Maybe if you have tire, you can take for a spin and let me know how does it feel for you.

I got few more tweak coming but I do no what to proceed before all these issue are closed.
Julio Jerez
Moderator
Moderator
 
Posts: 11048
Joined: Sun Sep 14, 2003 2:18 pm
Location: Los Angeles

Previous

Return to Bugs and Fixes

Who is online

Users browsing this forum: No registered users and 2 guests