Newton 3.14 vehicle problem

Report any bugs here and we'll post fixes

Moderators: Sascha Willems, Thomas

Newton 3.14 vehicle problem

Postby e3dalive » Mon Jan 18, 2016 2:45 am

Hey, it has been ~3 months and still no progress on fixing the vehicle jumping bug when intersecting 2 meshes in latest svn version, will it ever be fixed or have you completely forsaken vehicle code to work on something else?
e3dalive
 
Posts: 87
Joined: Thu Feb 05, 2015 5:20 am

Re: Newton 3.14 vehicle problem

Postby Julio Jerez » Wed Jan 27, 2016 3:55 pm

yes, is has now have some time to spend in the engine again, and I will fix the vehicle bug and work on the character system
Julio Jerez
Moderator
Moderator
 
Posts: 11039
Joined: Sun Sep 14, 2003 2:18 pm
Location: Los Angeles

Re: Newton 3.14 vehicle problem

Postby Julio Jerez » Sat Jan 30, 2016 2:11 pm

Ok please try getting the latest, I believe I have it fixed now.
sorry it took me so long to get to this bug :oops:
Julio Jerez
Moderator
Moderator
 
Posts: 11039
Joined: Sun Sep 14, 2003 2:18 pm
Location: Los Angeles

Re: Newton 3.14 vehicle problem

Postby e3dalive » Sun Jan 31, 2016 4:45 am

it still jumps a little on them, i also got an assert here CustomVehicleControlManager 1790 line, foundcontact is 0
video is here https://youtu.be/hMta5FlRDAc
also is there a function to set car position and orientation, previously i used direct method to just set new matrix, but now it sends the car flying and car looses it's wheels?
e3dalive
 
Posts: 87
Joined: Thu Feb 05, 2015 5:20 am

Re: Newton 3.14 vehicle problem

Postby Julio Jerez » Sun Jan 31, 2016 7:34 am

Yes I notice after I committed, reducing the contact to one, is not enough it make it better but is not enough, it should be the best of all contact.
I am working on it.
and yes I nee to probed a matrix set function, that apply to all bodies.
Julio Jerez
Moderator
Moderator
 
Posts: 11039
Joined: Sun Sep 14, 2003 2:18 pm
Location: Los Angeles

Re: Newton 3.14 vehicle problem

Postby e3dalive » Sun Jan 31, 2016 11:07 am

i also noted other strange bug when car moves between two meshes, rarely it gets stuck and car get sent into space, perhaps there is something wrong with my suspension(i noticed the value differ in sandbox with mine greatly sometimes 100 or 10000 times less)... I'm gonna wait for your next update
edit: i have adjusted suspension, the car turns and behaves much beter then it did originally, but there is little jumping every-now and then, i recorded a video https://youtu.be/gwh4WJnC0-8
e3dalive
 
Posts: 87
Joined: Thu Feb 05, 2015 5:20 am

Re: Newton 3.14 vehicle problem

Postby Julio Jerez » Sun Jan 31, 2016 11:37 am

I saw the flying bug when and two car collided, but is was so hard to reproduce that I have no debuged yet.
Please if you get again it again, can you make a video for me to see how you set the scene to reproduce it?

Meantime, I think I know what is the problem with the tire jump is now.
My fix make a little better but is does solve because of the tire penetration.
in 3.13 that did not happened because the tire was never allowed to penetrate the contact point.
in 3.14 this is no dealt with a regular contacts generate by newton contacts, by that deal with contact one at a time, instead of generally. This is why when going across object of edge it generate many contacts each with different high. the current solution is one contact that fist touches the tire.

to solve that bug I will import that functionality form 3.13.
Just wait few our, I should get this fix today.
Julio Jerez
Moderator
Moderator
 
Posts: 11039
Joined: Sun Sep 14, 2003 2:18 pm
Location: Los Angeles

Re: Newton 3.14 vehicle problem

Postby Julio Jerez » Sun Jan 31, 2016 11:45 am

hey can I mirror your video to post as 3.14 you video in YouTube tube.?
I recently deleted all newton videos. and I nee to start over.
Julio Jerez
Moderator
Moderator
 
Posts: 11039
Joined: Sun Sep 14, 2003 2:18 pm
Location: Los Angeles

Re: Newton 3.14 vehicle problem

Postby e3dalive » Sun Jan 31, 2016 12:03 pm

sure mirror it, you can also add some of my videos to your main site as made with newton if you want to
e3dalive
 
Posts: 87
Joined: Thu Feb 05, 2015 5:20 am

Re: Newton 3.14 vehicle problem

Postby Julio Jerez » Sun Jan 31, 2016 2:19 pm

oh thank you, I mirrored already,

meant time until I made the fix for the contact, I added the easy things first
these are the function form teleporting a vehicle
Code: Select all
dMatrix CustomVehicleController::GetTransform() const;
CustomVehicleController::SetTransform(const dMatrix& matrix);


I saw you video angry mouse, is that and example of the car flying around?
I assume the car should not do that since the mouse is much lighter than the car, ant the very least that are comparable masses.
can you tell me how you do the collision, what is the mouse made off and what are the masses of the mouse and the car?
Julio Jerez
Moderator
Moderator
 
Posts: 11039
Joined: Sun Sep 14, 2003 2:18 pm
Location: Los Angeles

Re: Newton 3.14 vehicle problem

Postby e3dalive » Sun Jan 31, 2016 3:28 pm

Thank you very much for that useful function. The video with moose uses old linear cast car, and moose were just for test. For now it's a simple box that pushes towards car(i don't use any force, i just directly move him, so it behaves like he has infinite mass), once i finish porting your new physics i should make him move with forces or linear velocity to make correct mass to mass simulation.
Last edited by e3dalive on Sun Jan 31, 2016 3:39 pm, edited 2 times in total.
e3dalive
 
Posts: 87
Joined: Thu Feb 05, 2015 5:20 am

Re: Newton 3.14 vehicle problem

Postby Julio Jerez » Sun Jan 31, 2016 3:32 pm

I forget to click sync, please sync again.
Julio Jerez
Moderator
Moderator
 
Posts: 11039
Joined: Sun Sep 14, 2003 2:18 pm
Location: Los Angeles

Re: Newton 3.14 vehicle problem

Postby e3dalive » Sun Jan 31, 2016 3:40 pm

Can you make BodyPartEngine::Info public or make old functions like SetInfo/GetInto, many of my gui requires to read that structure after it has set it up?
Also how can i enable reverse from the engine overload?
Integrated vehicle::SetTransform works great
i think i found the bug of the flying car, i recorder a video
i can also dump a list of torques i send to the car engine and wheel speed i recieve from that if that could help you to narrow it down, here is the video https://www.youtube.com/watch?v=SH1CYL-9Wks
e3dalive
 
Posts: 87
Joined: Thu Feb 05, 2015 5:20 am

Re: Newton 3.14 vehicle problem

Postby Julio Jerez » Mon Feb 01, 2016 2:23 pm

Code: Select all
Can you make BodyPartEngine::Info public or make old functions like SetInfo/GetInto, many of my gui requires to read that structure after it has set it up?
Also how can I enable reverse from the engine overload?

I will add those interface form the old code yes.

I see what you mean, you think that the jump happened because the the gear shift, and not a tire collision.
Let me make the modification that use convex cast instead of the continues collision routine first.
the you fix that bug.

I debug and compare 3.13 and 3.14 yesterday and I believe I know what is the problem,
in 3.14 the tire always using a convex cats to project the tire location to the fist contact.
I 3.14 I am using a Newton body for the tire so I can no do that, instead I am using collide continue,
however collide continues will no work when the tire is already in penetration.
I produce a contact, by the contact is already wrong.
I start to make the changed now, maybe a day or tow. then we look at that explosion bug.
Julio Jerez
Moderator
Moderator
 
Posts: 11039
Joined: Sun Sep 14, 2003 2:18 pm
Location: Los Angeles

Re: Newton 3.14 vehicle problem

Postby e3dalive » Wed Feb 03, 2016 6:58 am

ok, i will be waiting, hopefully it won't take more then a week :D
e3dalive
 
Posts: 87
Joined: Thu Feb 05, 2015 5:20 am

Next

Return to Bugs and Fixes

Who is online

Users browsing this forum: No registered users and 1 guest