CustomTriggerManager misses exit events

Report any bugs here and we'll post fixes

Moderators: Sascha Willems, Thomas

Re: CustomTriggerManager misses exit events

Postby aitzolmuelas » Wed Jul 15, 2015 11:52 am

I'm reusing this topic because the problem is basically the same: I tried the sandbox demos in the latest release and I still find issues in the trigger controller. If you try the advanced character demo, when you get to the top of the left ramp the ferry platform comes to you. If you then move on top of the platform, it is supposed to start moving back: however, this does not always work. From what I have been able to see, exit events are sometimes lost.
This issue is not bothering me, as I have finally had to implement triggers using collision queries with the 'foreachInAABB' call (there was no way of getting triggers to work properly in all cases using bodies) and this works fine for me, but I thought you might want to know.
aitzolmuelas
 
Posts: 78
Joined: Wed Mar 25, 2015 1:10 pm

Re: CustomTriggerManager misses exit events

Postby Julio Jerez » Wed Jul 15, 2015 1:42 pm

Oh thank you, yes the trigger is broken now, I noticed that too.

I have made few changes to the breaking phase 2.13 and now 3.14, and that is breaking a few things,
I am going over all the demos to bring the up to date with the latest changes.
I will check that triggers once and for all, this becoming are current issue, and we can no have that.

now I am going over the joint, and the I will check the collision parts. I actually doi to much on e engine side without checking the demos, and I still have some pending features, but I think I will left this for 3.15, hard joint and collision aggregates is enough for 3.14

The next two features are:
User contacts, and particle system.
Julio Jerez
Moderator
Moderator
 
Posts: 11039
Joined: Sun Sep 14, 2003 2:18 pm
Location: Los Angeles

Previous

Return to Bugs and Fixes

Who is online

Users browsing this forum: No registered users and 1 guest

cron