Linker error

Report any bugs here and we'll post fixes

Moderators: Sascha Willems, Thomas

Linker error

Postby Tinekk » Wed Dec 30, 2009 6:10 pm

Hello, when I download NewtonTutorials.rar (http://www.newtondynamics.com/downloads ... orials.rar) and compile it i get link errors.

Code: Select all
1>------ Build started: Project: Tutorial_101_GettingStarted, Configuration: Debug Win32 ------
1>Linking...
1>CollectInputAndUpdateCamera.obj : error LNK2019: unresolved external symbol "public: class dMatrix __thiscall dMatrix::operator*(class dMatrix const &)const " (??DdMatrix@@QBE?AV0@ABV0@@Z) referenced in function "void __cdecl UpdateCamera(float)" (?UpdateCamera@@YAXM@Z)
1>CollectInputAndUpdateCamera.obj : error LNK2019: unresolved external symbol "class dMatrix __cdecl dRollMatrix(float)" (?dRollMatrix@@YA?AVdMatrix@@M@Z) referenced in function "void __cdecl UpdateCamera(float)" (?UpdateCamera@@YAXM@Z)
1>CollectInputAndUpdateCamera.obj : error LNK2019: unresolved external symbol "class dMatrix __cdecl dYawMatrix(float)" (?dYawMatrix@@YA?AVdMatrix@@M@Z) referenced in function "void __cdecl UpdateCamera(float)" (?UpdateCamera@@YAXM@Z)
1>Entity.obj : error LNK2019: unresolved external symbol "public: __thiscall dMatrix::dMatrix(class dQuaternion const &,class dVector const &)" (??0dMatrix@@QAE@ABVdQuaternion@@ABVdVector@@@Z) referenced in function "public: virtual void __thiscall Entity::Render(float)" (?Render@Entity@@UAEXM@Z)
1>Entity.obj : error LNK2019: unresolved external symbol "public: class dQuaternion __thiscall dQuaternion::Slerp(class dQuaternion const &,float)const " (?Slerp@dQuaternion@@QBE?AV1@ABV1@M@Z) referenced in function "public: virtual void __thiscall Entity::Render(float)" (?Render@Entity@@UAEXM@Z)
1>OpenGlUtil.obj : error LNK2019: unresolved external symbol "public: class dVector __thiscall dMatrix::RotateVector(class dVector const &)const " (?RotateVector@dMatrix@@QBE?AVdVector@@ABV2@@Z) referenced in function "void __cdecl SetCamera(class dVector const &,class dVector const &)" (?SetCamera@@YAXABVdVector@@0@Z)
1>OpenGlUtil.obj : error LNK2019: unresolved external symbol "public: class dMatrix __thiscall dMatrix::Transpose(void)const " (?Transpose@dMatrix@@QBE?AV1@XZ) referenced in function "void __cdecl SetCamera(class dVector const &,class dVector const &)" (?SetCamera@@YAXABVdVector@@0@Z)
1>x32\Debug/Tutorial_101_GettingStarted.exe : fatal error LNK1120: 7 unresolved externals
1>Build log was saved at "file://c:\Users\Tinek\Desktop\NewtonTutorials\NewtonTutorials\Tutorial_101_GettingStarted\x32\Debug\BuildLog.htm"
1>Tutorial_101_GettingStarted - 8 error(s), 0 warning(s)
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========


I think there miss some .lib files. Please help me ;-)
Tinekk
 
Posts: 1
Joined: Wed Dec 30, 2009 6:06 pm

Return to Bugs and Fixes

Who is online

Users browsing this forum: No registered users and 2 guests

cron